Задать вопрос
18 августа, 00:17

среди натуральных чисел, меньших некоторого n, вычислить сумму чисел, которые делятся на 3 и не делятся на 5. написаты програму на языке Паскаль.

+2
Ответы (1)
  1. 18 августа, 02:45
    0
    uses crt;

    var

    a:array[1 ... 1000] of integer;

    i, n, sum:integer;

    begin

    write ('Введите число: ') ;

    read (n) ;

    for i:=1 to n-1 do

    if (i mod 3=0) and (i mod 50) then sum:=sum+i;

    write (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «среди натуральных чисел, меньших некоторого n, вычислить сумму чисел, которые делятся на 3 и не делятся на 5. написаты програму на языке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Из ряда натуральных чисел от 1 до 2000 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Из ряда натуральных чисел от 1 до 1500 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Сумма красивых чисел, меньших 30, равна 45 (10 + 12 + 23 = 45). Найдите сумму красивых натуральных чисел, меньших 10000
Ответы (1)