Задать вопрос
10 июля, 21:00

Вычислить значение суммы 9 членов следующего ряда: 20+1/k+1/2k+1/3k ... K>0 вводится с клавиатуры. 3 алгоритма по циклам

+3
Ответы (1)
  1. 11 июля, 00:51
    0
    Var

    i, k: longint;

    s: real;

    begin

    writeln ('Введите количество членов последовательности k') ;

    readln (k) ;

    s : = 20;

    for i : = 1 to k do

    s : = s + 1 / (i * k) ;

    writeln ('Сумма последовательности равна ', s)

    end.

    Тестовый пример:

    Введите количество членов последовательности k

    10

    Сумма последовательности равна 20.2928968253968

    Варианты, дающие те же результаты:

    var

    i, k: longint;

    s: real;

    begin

    writeln ('Введите количество членов последовательности k') ;

    readln (k) ;

    s : = 20;

    i:=1;

    while i<=k do begin

    s : = s + 1 / (i * k) ;

    i:=i+1

    end;

    writeln ('Сумма последовательности равна ', s)

    end.

    var

    i, k: longint;

    s: real;

    begin

    writeln ('Введите количестко членов последовательности k') ;

    readln (k) ;

    s : = 20;

    i:=1;

    repeat

    s : = s + 1 / (i * k) ;

    i:=i+1

    until i>k;

    writeln ('Сумма последовательности равна ', s)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить значение суммы 9 членов следующего ряда: 20+1/k+1/2k+1/3k ... K>0 вводится с клавиатуры. 3 алгоритма по циклам ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) приведите пример исполнителя алгоритма. 2) Должен ли составитель алгоритма знать, кто будет являться исполнителем алгоритма? 3) Перечислите свойства алгоритма. 4) Поясните значение свойства алгоритма "определенность".
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Найти сумму семи нечетных чисел натурального ряда, начиная с N>0. N вводится с клавиатуры. Сделать нужно по 3 циклам в паскале (repeat until, for to do, while do)
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)