Задать вопрос
12 июля, 04:19

Определите значение переменной z после выполнения фрагмента алгоритма:

z:=1;

repeat z:=z+2 until z=10;

1) 9

2) 11

3) 10

4) 1

5) ни один из вышеперечисленных ответов не верен, мой ответ:

И в целом объясните) как то меня ввела в тупик эта задача)

+2
Ответы (1)
  1. 12 июля, 05:38
    0
    Условие проверяется после декремента и если истинно, то цикл завершается

    1

    +2=3

    +2=5

    +2=7

    +2=9

    +2=11

    +2=13

    выходит, что цикл не завершится по условию, т. к. не попадёт в "10",

    вариант ответа №5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определите значение переменной z после выполнения фрагмента алгоритма: z:=1; repeat z:=z+2 until z=10; 1) 9 2) 11 3) 10 4) 1 5) ни один из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=2; for i:=0 to 2 do begin a:=a+i; end; Ответ: введите число 4.
Ответы (2)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
1) приведите пример исполнителя алгоритма. 2) Должен ли составитель алгоритма знать, кто будет являться исполнителем алгоритма? 3) Перечислите свойства алгоритма. 4) Поясните значение свойства алгоритма "определенность".
Ответы (1)
1) Определите значение переменных a и b после выполнения фрагмента алгоритма: a: = 86; b: = a mod 10 + 14; a: = а div 3 * 5; 2) Определите значение переменных a и b после выполнения фрагмента алгоритма: a: = 8673; b: = (a mod 100) * 10 + 14;
Ответы (1)
Что появится на экране после выполнения фрагмента программы? а:=9; b:=5; if (a mod b) mod 2=0 then write ('yes') else write ('no') ; Определите значение переменной а после выполнения алгоритма: a:=4; b:=9; b:=6*b-a; a:=b/5*3-a;
Ответы (1)