Задать вопрос
9 февраля, 18:47

Написать программу при выполнение которой с клавиатуры вводятся 10 целых чисел. Программа выводит кол-во чисел кратных 5 и её произведение.

+3
Ответы (1)
  1. 9 февраля, 20:55
    0
    Var

    a : array [1 ... 10] of integer;

    count, prod, i : integer;

    begin

    count : = 0;

    prod : = 1;

    for i : = 1 to 10 do read (a[i]) ;

    for i : = 1 to 10 do

    if a[i] mod 5 = 0 then

    begin

    count : = count + 1;

    prod : = prod * a[i];

    end;

    if count > 1 then write (count, ' ', prod) else write ('таких чисел нет') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу при выполнение которой с клавиатуры вводятся 10 целых чисел. Программа выводит кол-во чисел кратных 5 и её произведение. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами.
Ответы (1)
Паскаль ABC Пользователь вводит с клавиатуры два числа. Если сумма чисел больше, либо равна 100, то программа выводит "Разряд выше десятков", если сумма меньше 100, но больше либо равна 10, то программа выводит "Разряд выше единиц", если сумма чисел
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)