Задать вопрос
7 марта, 20:38

На языке паскаль:

1. Проверить, делится ли произведение пяти натуральных чисел на первое из них нацело. 2. Определите количество двузначных чисел, сумма квадратов цифр которых делится без остатка на 15.

+5
Ответы (1)
  1. 7 марта, 21:29
    0
    1.

    uses crt;

    var a, b, c, d, e, f:integer;

    begin

    writeln ('vvedite 5 chisel') ;

    read (a, b, c, d, e) ;

    f:=a*b*c*d*e;

    if (f mod a) = 0

    then writeln ('delitsa')

    else writeln ('nedelitsa') ;

    end.

    По поводу второй, не уверен, если под суммой квадратов цифр подразумевается 10 = 1*1+0*0, то эта программа неправильна, её нужно переписать будет.

    uses crt;

    var a, i, s, t, t1:integer;

    begin

    for i:=10 to 99 do begin

    t:=i div 10; t1:=i mod 10;

    if (sqr (t) + sqr (t1)) mod 15 = 0

    then s:=s+1;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На языке паскаль: 1. Проверить, делится ли произведение пяти натуральных чисел на первое из них нацело. 2. Определите количество двузначных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)