Задать вопрос
30 января, 02:07

Написать программу в паскалabc

Даны 3 числа. Определить, можно ли построить треугольник с указанными сторонами.

+5
Ответы (1)
  1. 30 января, 02:40
    0
    Program triangle;

    var

    max, a, b, c, s:integer;

    begin

    readln (a, b, c) ;

    max:=a;

    if b > max then begin

    max:=b;

    s:=a+c;

    if s > max then writeln ('Мoжно')

    else

    writeln ('Нельзя') ;

    end;

    if c > max then begin

    max:=c;

    s:=a+b;

    if s > max then writeln ('Мoжно')

    else

    writeln ('Нельзя') ;

    end

    else

    s:=c+b;

    if s > max then writeln ('Мoжно')

    else writeln ('Нельзя') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в паскалabc Даны 3 числа. Определить, можно ли построить треугольник с указанными сторонами. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Требовалось написать программу, 1) Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у, z. Программа должна выводить соответствующее текстовое сообщение.
Ответы (1)
1) Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у, z. Программа должна выводить соответствующее текстовое сообщение. Программист сделал в программе ошибки.
Ответы (1)
напишите программу: даны действительные числа a b c. если нельзя построить треугольник с такими сторонами то напечатать 0, иначе 3,2 или 1 в зависимости от того, равносторонний этот треугольник, равнобедренный или какой-либо другой.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Даны три отрезка со сторонами a, b, c. Выяснить можно ли построить треугольник с данными сторонами, если - да, то переменной y присвоить значение 1, иначе - 0.
Ответы (1)