Задать вопрос
27 июня, 22:35

Среди введённых n чисел найти сумму всех чётных чисел. (В Pascal)

+3
Ответы (1)
  1. 27 июня, 23:45
    0
    Program gt;

    var n, i, a, s:integer;

    begin

    readln (n) ;

    s:=0;

    for i:=1 to n do

    begin

    read (a) ;

    if (a mod 2=0) then s:=s+a;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Среди введённых n чисел найти сумму всех чётных чисел. (В Pascal) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
С клавиатуры вводятся 3 числа. Найти количество и сумму четных чисел среди них. Если среди введенных четных нет, то вывести соответствующее сообщение.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
Написать программу в Pascal Даны число A>0, числа x1, x2 ... Необходимо вводить числа x1, x2 ..., пока сумма модулей введенных чисел будет меньше A. Определить число введенных чисел. P.
Ответы (1)