Задать вопрос
26 февраля, 08:32

Дано N чисел, написать программный код в паскале абц, которая находит номер самого большого числа в последовательности.

+5
Ответы (1)
  1. 26 февраля, 12:20
    0
    Const

    N = 10;

    var

    i, k, max: integer;

    a: array[1 ... N] of integer;

    begin

    Writeln ('Исходные данные') ;

    Randomize;

    for i : = 1 to N do

    begin

    k : = random (100) - 50;

    a[i] : = k;

    write (k:4)

    end;

    writeln;

    max : = - 32768; / / меньше не бывает

    for i : = 1 to N do

    if max < a[i] then max : = a[i];

    writeln ('Максимальное из чисел равно ', max)

    end.

    Тестовый пример:

    Исходные данные

    39 - 42 - 3 3 - 37 - 32 25 43 24 - 17

    Максимальное из чисел равно 43
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано N чисел, написать программный код в паскале абц, которая находит номер самого большого числа в последовательности. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
На языке программирования Паскаль напишите программу, которая: 1) В последовательности чисел находит количество чисел, кратных 3. 2) В последовательности чисел находит максимальное четное число, оканчивающееся на 4.
Ответы (1)
1. Найти разность 31 (10) - 16 (10) в восьмибитном представлении. Прямой код, обратный код и дополнительный код. 2. Представить число - 292 (10) в двоичном виде в шестнадцатибитном представлении в формате целого со знаком.
Ответы (1)
Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.
Ответы (1)