Задать вопрос
6 февраля, 08:06

Составить программу подсчитывающую сколько дней в январе было с температурой выше, ниже и равной средней температуре месяца

+5
Ответы (1)
  1. 6 февраля, 08:30
    0
    Var

    m: array [1 ... 31] of integer; / / заполненный массив

    sr: real; / / средняя сумма

    sum: integer; / / сумма всех элементов

    i: integer;

    a: integer; //значений выше

    b: integer; //значений ниже

    c: integer; //равных среднему

    begin

    for i : = 1 to 31 do

    sum : = sum + m[i];

    sr : = sum / 31;

    for i : = 1 to 31 do

    if m[i] > sr then

    a : = a + 1

    else if m[i] < sr then

    b : = b + 1

    else c : = c + 1;

    writeln (a) ;

    writeln (b) ;

    writeln (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу подсчитывающую сколько дней в январе было с температурой выше, ниже и равной средней температуре месяца ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задание 1. Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе. Пример: Введите номер месяца: -2 Введите номер месяца: 11 В этом месяце 30 дней. Вы вводили неверно 1 раз. Задание 2.
Ответы (1)
Как-то раз мистер Фокс и его друзья (Форд, Окс, Орд, Фок и Фор) решили узнать, кто всех выше, а кто всех ниже. Им удалось выяснить, что Фокс ниже Орд, Окс выше Фор, Форд ниже Фок, Окс ниже Фокс, а Форд выше Орд. Выстройте зверей по росту.
Ответы (1)
Как-то раз мистер Фокс и его друзья (Форд, Окс, Орд, Фок и Фор) решили узнать, кто всех выше, а кто всех ниже. Им удалось выяснить, что Форд ниже Окс, Орд выше Фор, Фокс ниже Фок, Орд ниже Форд, а Фокс выше Окс. Выстройте зверей по росту.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
9. Саша, Маша, Андрей, Витя, Боря и Гриша живут в многоэтажном доме. Витя живет выше Гриши. Андрей - ниже Саши. Боря выше Вити, но ниже Маши. Саша - ниже Маши и Бори. Кто живёт выше остальных?
Ответы (1)