Задать вопрос
25 января, 15:19

Даны следующие типы данных:

type Date = record

day : 1 ... 31;

mounth : 1 ... 12;

year : integer;

end;

Person = record

SurnameName : string;

Birthday : date;

end;

ListOfPeople = array [1 ... 50] of person;

напишите программу, которая вводит с клавиатуры данные о n лицах (n<=50) и выводит на экран:

фамилию и имя самого младшего человека

+3
Ответы (1)
  1. 25 января, 18:57
    0
    Program Pro1;

    type Date = record

    day : 1 ... 31;

    mounth : 1 ... 12;

    year : integer;

    end;

    Person = record

    SurnameName : string;

    Birthday : date;

    end;

    ListOfPeople = array [1 ... 50] of person;

    var

    People: ListOfPeople;

    JoungHuman: Integer;

    i, JoungHumanIndex: Byte;

    begin

    for i:=1 to 50 do

    begin

    Write (' Human '+IntToStr (i) + ':')

    Write ('Input Surname and Name:')

    ReadLn (People[i]. SurnameName) ;

    Write ('Input Birthday date (day, mounth, year) : ')

    Read (People[i]. Birthday. day, People[i]. Birthday. mounth, People[i]. Birthday. year) ;

    end;

    //

    JoungHumanIndex:=1;

    //

    JoungHuman:=People[1]. Birthday. day + People[1]. Birthday. mounth*13 + People[1]. Birthday. year * 32 * 13;

    for i:=2 to 50 do

    if JoungHuman> People[i]. Birthday. day + People[i]. Birthday. mounth*13 + People[i]. Birthday. year * 32 * 13 then

    begin

    //

    JoungHumanIndex:=i;

    //

    JoungHuman:=People[i]. Birthday. day + People[i]. Birthday. mounth*13 + People[i]. Birthday. year * 32 * 13;

    end;

    WriteLn ('Most joung human: ' + People[JoungHumanIndex]. SurnameName) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны следующие типы данных: type Date = record day : 1 ... 31; mounth : 1 ... 12; year : integer; end; Person = record SurnameName : ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике