Задать вопрос
26 июня, 03:10

Помогите решить задачу:

C клавиатуры вводится число n. Если оно положительное, то выведите n^2 (n*n). А если отрицательное, то выведите 0.

+5
Ответы (1)
  1. 26 июня, 03:24
    0
    program Project2;

    uses Crt;

    var

    n:real; / / переменная n типа real begin

    readln (n) ; / / считываем число с клавиатуры и кладем в переменную n

    if (n < 0) then n : = n * n else n : = sqrt (n) ; / / если n меньше нуля, то перемножаем n на n иначе берем корень квадратный из n

    writeln (n:4:4) ; / / выводим полученное число, 4:4 нужно для обрезания дроби, чтобы не получилось + E100000000 (как пример) readln; / / ждем нажатия enter, чтобы программа сразу не завершилась после вывода результата end. Если будет ругаться на sqrt (n) тогда там где uses Crt пропишите uses Crt, Math;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачу: C клавиатуры вводится число n. Если оно положительное, то выведите n^2 (n*n). А если отрицательное, то выведите 0. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
1) Вычислить и вывести на экран сумму тех целых чисел из промежутка от 1 до K, которые не делятся на 5 без остатка. K вводится с клавиатуры. 2) С клавиатуры вводится целое положительное число. Определить, сколько в числе цифр.
Ответы (1)