Задать вопрос
5 мая, 12:12

Напечатать заданный текст с удалением из него всех букв b, непосредственно перед которыми находится буква с.

+1
Ответы (1)
  1. 5 мая, 13:13
    0
    var

    s: string;

    i: integer;

    begin

    readln (s) ;

    i : = 1;

    while (i < length (s)) do

    begin

    if ((s[i] = 'b') and (s[i + 1] = 'c')) then

    delete (s, i, 1) ;

    i : = i + 1;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напечатать заданный текст с удалением из него всех букв b, непосредственно перед которыми находится буква с. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу для паскаля! Дано натуральное число. Найти число, получаемое удалением удалением из исходного всех цифр а.
Ответы (1)
1. (Char). Пользователь вводит текст, признаком конца которого является точка. Напечатать true, если буква "а" встречается чаще, чем буква "в", и напечатать false в противном случае.
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Составить программу которая удаляет из строки заданный символ (,) и вставляет в строку другой заданный символ (.)
Ответы (1)
1. Переведите на язык программирования: а) ввести А и С увеличить А в 10 раз уменьшить С в 20 раз напечатать модуль разности А и С б) ввести А и С если А>С, то увеличить А в 5 раз иначе уменьшить С в 2 раза напечатать значения А и С конец в) ввести
Ответы (1)