Задать вопрос
4 декабря, 07:50

1. составить программу входе которой определяется входит ли цифры 4 или 7 в данной 2 х значное число.

2. Составить программу входи работы которой определяется является ли данное число кратное и оканчивающиеся на 3

+1
Ответы (1)
  1. 4 декабря, 11:11
    0
    Язык не указан, Default-Language это C. На нём и напишу.

    1.

    #include

    int main ()

    Для порядку скажу что на Perl это можно реализовать проще.

    #! perl

    %h { 4 = > 0, 7 = > 0};

    ;

    if (exists $h{$_%10} || exists $h{$_/10}) {

    print "YES/n";

    else {

    print "NO/n";

    }

    Но мы ушли от темы. Итак, 2. Тут всё ещё проще:

    #include

    int main () {

    int n;

    scanf ("%d", &n) ;

    if (! (n % 3))

    printf ("Multiple of 3/n") ;

    else

    printf ("Not multiple of 3/n") ;

    if (n % 10 = = 3)

    printf ("Ends by 3/n") ;

    else

    printf ("Not ends by 3/n") ;

    return 0;

    }

    Тут более простой реализации на другом известном мне языке нету, так что приводить дополнительно ничего не буду.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. составить программу входе которой определяется входит ли цифры 4 или 7 в данной 2 х значное число. 2. Составить программу входи работы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы