Задать вопрос
30 января, 02:06

Нужно решить задачу в Паскале, условие таково:

Пользователь вводит число заранее неизвестное.

Выяснить есть ли в этом числе хотя бы две одинаковые цифры.

+4
Ответы (1)
  1. 30 января, 02:38
    0
    Program zz;

    var a, z, z1, z2, z3, z4, z5, z6, z7, z8, x:integer;

    begin

    readln (a) ;

    while a>0 do

    begin

    x:=a mod 10;

    if x=1 then z:=z+1;

    if x=2 then z1:=z+1;

    if x=3 then z2:=z2+1;

    if x=4 then z3:=z3+1;

    if x=5 then z4:=z4+1;

    if x=6 then z5:=z5+1;

    if x=7 then z6:=z6+1;

    if x=8 then z7:=z7+1;

    if x=9 then z8:=z8+1;

    a:=a div 10;

    end;

    if (z>1) or (z1>1) or (z2>1) or (z3>1) or (z4>1) or (z5>1) or (z6>1) or (z7>1) or (z8>1)

    then writeln ('yes')

    else writeln ('no') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно решить задачу в Паскале, условие таково: Пользователь вводит число заранее неизвестное. Выяснить есть ли в этом числе хотя бы две ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите с программой. Пользователь вводит с клавиатуры сумму, которая у него есть. Далее"садится за рулетку". Программа спрашивает, какая ставка и на что ставит. пользователь. Ставка идет на конкретное число (от 1 до 36).
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Какое событие наступит после того, как: А) ученик встретит учителя Б) пользователь выберет команду меню В) пользователь выберет объект правой кнопкой мыши Г) пользователь включит компьютер Д) пользователь перетянет левый нижний угол окна
Ответы (1)
Пользователь клавиатуры вводит в минуту 60 знаков. Какое количество текстовой информации вводит этот пользователь за 5 минут в кодировке Unicode?
Ответы (1)