Задать вопрос
15 мая, 06:30

Даны натуральные число n, действительные числа a1, ... an. Вычислить а1 + ... + an. На паскале

+2
Ответы (1)
  1. 15 мая, 06:53
    0
    Var a, s:real; i:integer;

    begin

    write ('Введи натуральное число n = ') ; readln (n) ;

    s:=0;

    for i: = 1 to n do begin

    readln (a) ; s:=s+a;

    end;

    write ('S = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны натуральные число n, действительные числа a1, ... an. Вычислить а1 + ... + an. На паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача№1. Найти произведение цифр заданного трехзначного числа. Задача№2. Вычислить выражение y=cos (1) + cos (1/2) + cos (1/3) + ... + cos (1/n), где n вводить с клавиатуры. Задача№3. Даны действительные числа а1, а2 ... а n.
Ответы (1)
Это цикл for: 1) даны натуральные числа X и Y. вычислить X*Y, пользуясь только оперцией сложения. 2) даны натуральные числа X и Y. вычислить X^Y 3) дано натуральное число N. найти сумму S=1+1/2+1/3 + ... + 1/N. 4) дано натуральное число N и число Х.
Ответы (1)
Написать программу на паскале Даны действительные числа x, y. Вычислить значение функции z=arcsin (x+y)
Ответы (1)
Решите в паскале 1. Даны действительные числа x, y. Вычислить их разность и частное. 2. Дана сторона квадрата. Найти периметр, площадь и диагональ квадрата.
Ответы (1)
Даны действительные числа x, y, z Если все числа положительны, увеличить их значения в 2 раза; во всех отальных случаях отрицательные числа заменить их модулями, а положительные оставить без изменения. (Надо написать программу на паскале)
Ответы (1)