Задать вопрос
5 февраля, 09:49

Составить программу, которая в зависимости от порядкового номера месяца выводит на экран количество дней в этом месяце. Рассмотреть два случая: 1. год високосный.

2. год не является високосным

+5
Ответы (1)
  1. 5 февраля, 10:04
    0
    Program G;

    Uses Crt;

    Var count, num, ch: integer;

    Begin

    ClrScr;

    Writeln ('Год високосный? 1 - да, 0 - нет') ;

    Readln (Ch) ;

    If ch=1 then

    Begin

    Writeln ('Введите номер месяца') ;

    Readln (num) ;

    Сase num of

    1, 3, 5, 7, 8, 10, 12: writeln ('В месяце 31 день.') ;

    4, 6, 9, 11: writeln ('В месяце 30 дней.') ;

    2: writeln ('В месяце 29 дней') ;

    else writeln ('Некорректный ввод данных')

    End;

    End

    Else if ch=0 then

    Begin

    Writeln ('Введите номер месяца') ;

    Readln (num) ;

    Сase num of

    1, 3, 5, 7, 8, 10, 12: writeln ('В месяце 31 день.') ;

    4, 6, 9, 11: writeln ('В месяце 30 дней.') ;

    2: writeln ('В месяце 28 дней') ;

    else writeln ('Некорректный ввод данных')

    End;

    End

    Else writeln ('Некорректный ввод данных') ;

    Readln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая в зависимости от порядкового номера месяца выводит на экран количество дней в этом месяце. Рассмотреть два ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, определяющую количество дней в месяце Алгоритм решения задачи: Переменная d имеет тип данных запись и содержит два поля: year - для хранения года и month - для месяца. Пользователь вводит год и месяц.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Составить программу в Pascal ABC, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число. После этого выводит сообщение о том, сколько дней осталось до конца месяца.
Ответы (1)
Составить программу, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число. После этого выводит сообщение о том, сколько дней осталось до конца месяца.
Ответы (1)
Python:Дано натуральное число. Требуется определить, является ли год с данным номером високосным. Если год является високосным, то выведите YES, иначе выведите NO.
Ответы (1)