Задать вопрос
23 сентября, 11:27

Если введенное с клавиатуры число (не равное нулю) положительно вычислить его квадрат, а если отрицательно - умножить его на 2

+4
Ответы (1)
  1. 23 сентября, 12:19
    0
    Var

    a, b:Integer;

    Begin

    Writeln ('Введите число - ') ; Readln (a) ;

    if (a>0) then b:=a*a else if (a<0) then b:=a*2;

    Writeln ('Ответ: ', b) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Если введенное с клавиатуры число (не равное нулю) положительно вычислить его квадрат, а если отрицательно - умножить его на 2 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Если целое число М, введенное с клавиатуры, делится на целое число Н, введенное с клавиатуры, с остатком равным 2, то вывести на экран целую часть от деления М на Н, в противном случае - сообщение "при делении ... на ... остаток не равен 2"
Ответы (1)
Удвоить трехзначное число, введенное с клавиатуры, если оно содержит в своей записи хотя бы одну единицу, и возвести в квадрат в другом случае. Если введенное число не трехзначное, вывести сообщение об ошибке.
Ответы (1)
напишите класс который принимает с клавиатуры целое число и выводит на экран его квадрат но только в случае, если введенное число отрицательно. В противном случае на экран выводится сообщение ошибка
Ответы (2)
1) Проверка условия и ветвление в алгоритме. Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран: а) удвоенное значение числа, если число положительное; б) абсолютное значение числа, если число отрицательное.
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)