Задать вопрос
10 сентября, 04:50

Двно целое число n. Составить программу нахождения количества цифр числа

+5
Ответы (1)
  1. 10 сентября, 05:12
    0
    Var

    a:longint;

    s:string;

    begin

    writeln ('Введите целое положительное число') ;

    readln (a) ;

    Str (a, s) ;

    writeln ('Количество цифр в числе равно ', length (s)) ;

    end.

    Тестовый пример:

    Введите целое положительное число

    23434232

    Количество цифр в числе равно 8
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Двно целое число n. Составить программу нахождения количества цифр числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)
Дано целое число N. Составить программу нахождения количества цифр числа (Pascal ABC)
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Free Pascal 1. Составить программу для вычисления площади прямоугольника по его длинам сторон a и b. 2. Даны два целых числа x и y. Составить программу для нахождения большего из них. 3.
Ответы (1)