Задать вопрос
15 апреля, 01:27

Составить программу на языке паскаль. Составить блок схему.

Дан массив вещественных чисел. Ко всем отрицательным элементам прибавить элемент с номером, к остальным - элемент с номером.

+5
Ответы (1)
  1. 15 апреля, 02:53
    0
    Const

    m=10;

    var

    i, s, n, m1, m2:integer;

    a:array[1 ... m]of integer;

    begin

    write ('Исходный массив: ') ;

    for i:=1 to m do

    begin

    a[i]:=random (-5,10) ;

    write (a[i],' ') ;

    end;

    writeln;

    repeat

    write ('Введите m1 и m2: ') ;

    readln (m1, m2) ;

    until (m1>0) and (m2>0) and (m1<=m) and (m2<=m) ;

    n:=a[m1];

    s:=a[m2];

    write ('Измененный массив: ') ;

    for i:=1 to m do

    begin

    if a[i]<0 then a[i]:=a[i]+n

    else a[i]:=a[i]+s;

    write (a[i],' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на языке паскаль. Составить блок схему. Дан массив вещественных чисел. Ко всем отрицательным элементам прибавить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Задачи на массив (паскаль) : Массив (подсчёт суммы) а) Дан массив целых чисел. Найти сумму нечётных элементов. б) Дан массив. Определить максимальный и минимальный элемент.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)