Задать вопрос
20 июля, 04:47

Составить программу формирующую двухмерный массив 10^10 заполненный нулями, затем вывести на экран, затем преобразовать таким образом чтобы элементы главной диагонали были равны 1

+5
Ответы (1)
  1. 20 июля, 05:04
    0
    Program array

    var

    i, j:integer;

    a: array [1 ... 10, 1 ... 10] of integer;

    begin

    for i:=1 to 10 do begin

    for j:=1 to 10 do begin

    a[i, j] = 0;

    writeln (a[i, j],"/t") ;

    end;

    end;

    for i:=1 to 10 do begin

    for j:=1 to 10 do begin

    if (i = j) then a[i, j] = 1;

    writeln (a[i, j],"/t") ;

    end;

    end;

    end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу формирующую двухмерный массив 10^10 заполненный нулями, затем вывести на экран, затем преобразовать таким образом чтобы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Дан двухмерный массив A (n, m). Найти произведение отрицательных четных элементов второго столбца массива. 2. Дан двухмерный массив m*n. Получите одномерный массив b, элементы которого равны min элементам по строкам.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)