Задать вопрос
30 декабря, 15:55

Записать программу формирования и выделения n элементов паскаль n<=1000 первые n простых чисел

+1
Ответы (1)
  1. 30 декабря, 17:55
    0
    Function Simple (a: integer) : boolean;

    begin

    result : = true;

    for i: integer : = 2 to (a div 2) do

    if (a mod i = 0) then

    begin

    result : = false;

    break;

    end;

    end;

    const

    n = 10;

    var

    i: longint : = 1;

    j: longint;

    a: array [1 ... n] of longint;

    begin

    while (a[n] = 0) do

    begin

    while (a[i] = 0) do

    begin

    j + = 1;

    if (Simple (j)) then

    begin

    a[i] : = j;

    end;

    end;

    i + = 1;

    end;

    for i : = 1 to n do

    write (a[i], ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Записать программу формирования и выделения n элементов паскаль n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)