Задать вопрос
21 сентября, 19:00

1. Найти значение и номер первого отрицательного члена последовательности cos (сtg n) = 1,2,3 ...

+3
Ответы (1)
  1. 21 сентября, 22:41
    0
    Var

    x: real;

    begin

    x : = 1;

    while (cos (1 / tan (x)) > = 0) do x : = x + 1;

    Write (x, ': ', cos (1 / tan (x)))

    end.

    Результат выполнения программы:

    6: - 0.956871790478342

    Если нужна промежуточная печать:

    var

    x: real;

    begin

    x : = 1;

    while (cos (1 / tan (x)) > = 0) do begin

    Writeln (x, ': ', cos (1 / tan (x))) ;

    x : = x + 1

    end;

    Writeln (x, ': ', cos (1 / tan (x)))

    end.

    Результат выполнения программы:

    1: 0.800844301895226

    2: 0.897089962539917

    3: 0.743794228654611

    4: 0.64963571596558

    5: 0.956565479264333

    6: - 0.956871790478342
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Найти значение и номер первого отрицательного члена последовательности cos (сtg n) = 1,2,3 ... ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
1. Вычислить сумму ряда s = cos (x) + cos (x) * cos (x) + ... + cos (x) * cos (x) * ... * cos (x), для x и n введенных с клавиатуры.
Ответы (2)
Рассмотрим последовательность, образованную дробями: 1/1, 2/1, 3/2, ..., в которой числитель (знаменатель) следующего члена последовательности получается сложением числителей (знаменателей) двух предыдущих членов.
Ответы (1)
1. В последовательности чисел подсчитать произведение чисел, кратных 3. 2. В последовательности чисел сравнить, что больше сумма положительных или про-изведение отрицательных. 3.
Ответы (1)