Задать вопрос
27 апреля, 23:28

Будем называть количество делителей числа n его красотой. Например, красота числа 12 равна 6. Требуется написать программу, которая по числу k (1 ≤ k ≤ 109) найдет число с максимальной красотой, не превышающее k.

+4
Ответы (1)
  1. 28 апреля, 00:48
    0
    Program gt;

    var k, t, max, i, h, j, l:integer;

    begin

    readln (k) ;

    max:=0;

    for i:=1 to k do

    begin

    l:=round (sqrt (i)) ;

    h:=0;

    for j:=1 to l do

    if (i mod j=0) then h:=h+1;

    h:=2*h;

    if (l*l=i) then h:=h-1;

    if (h>max) then begin

    max:=h;

    t:=i;

    end;

    end;

    writeln (t) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Будем называть количество делителей числа n его красотой. Например, красота числа 12 равна 6. Требуется написать программу, которая по ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Играют двое. Первый участник игры называет произвольное целое положительное число, не превышающее десяти, то есть он может назвать число десять и всякое меньшее десяти положительное число.
Ответы (1)
Проверить являются ли два введенных числа дружественными. Дружественные числа - пара чисел, каждое из которых равно сумме собственных делителей другого (Делителем числа называется всякий его делитель, отличный от самого числа) Дружественные числа
Ответы (1)
Помогите написать программу в python Уровень C. Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год", "года" или "лет". Например, "21 год", "22 года", "25 лет".
Ответы (2)
Пользователь вводит положительное целое число, не превышающее 10^9, нужно написать программу, которая выводит на экран сумму цифр этого числа, меньших 7. если в числе нет цифр, меньших 7, требуется на экран вывести 0
Ответы (2)
Напишите программу, которая вводит целое число, не превышающее 100, и выводит его прописью, например: 21>"Двадцать один"
Ответы (1)