Задать вопрос
28 ноября, 18:12

Напишите программу, которая вводит целое число, не превышающее 100, и выводит его прописью, например: 21>"Двадцать один"

+1
Ответы (1)
  1. 28 ноября, 21:22
    0
    Program abc;

    var

    a, b, c, t, z:integer;

    m, k, l:string;

    label 1,2,3,4;

    begin

    writeln ('Введите число от 1-го до 100') ;

    repeat read (a) until (a>=0) and (a<=100) ;

    b:=a div 10;

    c:=a mod 10;

    if a=100 then goto 2;

    if a=0 then goto 1;

    if (a>9) and (a<20) then goto 4;

    case b of

    2:m:='Двадцать ';

    3:m:='Тридцать ';

    4:m:='Сорок ';

    5:m:='Пятьдесят ';

    6:m:='Шестдесят ';

    7:m:='Семдесят ';

    8:m:='Восемьдесят ';

    9:m:='Девяносто '; end;

    case c of

    1:k:='один';

    2:k:='два';

    3:k:='три';

    4:k:='четыре';

    5:k:='пять';

    6:k:='шесть';

    7:k:='семь';

    8:k:='восемь';

    9:k:='девять';

    end;

    writeln (m, k) ;

    goto 3;

    2:writeln ('Сто') ;

    goto 3;

    1: writeln ('Ноль') ;

    goto 3;

    4: if a=10 then writeln ('Десять') ;

    if a=11 then writeln ('Одиннадцать') ;

    if a=12 then writeln ('Двенадцать') ;

    if a=13 then writeln ('Тринадцать') ;

    if a=14 then writeln ('Четырнадцать') ;

    if a=15 then writeln ('Пятьнадцать') ;

    if a=16 then writeln ('Шестнадцать') ;

    if a=17 then writeln ('Семнадцать') ;

    if a=18 then writeln ('Восемнадцать') ;

    if a=19 then writeln ('Девятнадцать') ;

    3:end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая вводит целое число, не превышающее 100, и выводит его прописью, например: 21>"Двадцать один" ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
напишите программу, которая вводит возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год", "года" или "лет". например: 21 год, 22 года, 25 лет
Ответы (1)
Помогите написать программу в python Уровень C. Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год", "года" или "лет". Например, "21 год", "22 года", "25 лет".
Ответы (2)
Пользователь вводит положительное целое число, не превышающее 10^9, нужно написать программу, которая выводит на экран сумму цифр этого числа, меньших 7. если в числе нет цифр, меньших 7, требуется на экран вывести 0
Ответы (2)
3. Напишите и выполните программу на компьютере a. Программа вводит одно число, и вычисляет его квадрат, вычитая из него удвоенное значение введенного числа. b. Программа вводит два числа, выводит сумму квадратов этих чисел минус их произведение. c.
Ответы (1)