Задать вопрос
18 ноября, 16:29

Составить программу которая позволяет найти наименьший элемент случайно сформированного одномерного массива

+1
Ответы (1)
  1. 18 ноября, 18:24
    0
    Easy

    const

    n=10;

    r=99;

    var

    i:integer;

    min:integer;

    m:array[1 ... n] of integer;

    begin

    randomize;

    min:=maxint; / / Или intmax

    for i:=1 to n do

    begin

    m[i]:=random (99) + 1; / / заполняем случайно от 1 до 99

    write (m[i],' ') ;

    end;

    writeln;

    for i:=1 to n do if min>m[i] then min:=m[i];

    write (min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу которая позволяет найти наименьший элемент случайно сформированного одномерного массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Создать программу получения и обработки одномерного массива - вектора: Определить наименьший элемент элемент нечетных по номеру элементов второй четверти массива.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)