Задать вопрос
28 июля, 06:27

Создать программу получения и обработки одномерного массива - вектора:

Определить наименьший элемент элемент нечетных по номеру элементов второй четверти массива.

+3
Ответы (1)
  1. 28 июля, 06:54
    0
    Const n=20;

    var a:array[1 ... n] of integer;

    i, min:integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    a[i]:=random (101) ;

    write (a[i]:4) ;

    end;

    writeln;

    min:=1000;

    for i:=n div 4+1 to n div 2 do

    if (i mod 2 = 1) and (a[i]
    writeln ('min = ', min) ;

    end.

    Пример:

    88 6 45 6 2 72 92 83 55 96 4 52 33 81 62 79 51 46 9 82

    min = 55
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Создать программу получения и обработки одномерного массива - вектора: Определить наименьший элемент элемент нечетных по номеру элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Создать программу получения и обработки одномерного массива - вектора: Вычислить значения 35 элементов одномерного целочисленного массива F в интервале (-6, 10) с использованием генератора случайных чисел
Ответы (1)
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)