Задать вопрос
3 августа, 08:42

Вычислить среднее арифметическое положительных элементов массива F (M)

+5
Ответы (1)
  1. 3 августа, 11:14
    0
    Program primer;

    const n=10;

    var f:array[1 ... n] of integer;

    k, s, m:integer; sr:real;

    begin

    writeln ('vvedite massiv') ;

    for m:=1 to n do

    readln (f[m]) ;

    k:=0;

    s:=0;

    for m:=1 to n do

    if f[m]>0 then begin

    s:=s+f[m];

    inc (k) ;

    end;

    sr:=s/k;

    writeln ('sr=', sr) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить среднее арифметическое положительных элементов массива F (M) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1 задача: Массив Z (20) заполнить целыми случайными числами в диапазоне от - 20 до 20. Вычислить CP - среднее арифметическое положительных элементов и CN - среднее арифметическое отрицательных элементов массива Z.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)