Задать вопрос
18 ноября, 10:13

Составить

программу, которая подсчитывает общее количество целых пятизначных чисел, составленных

из различных цифр, которые обладают тем свойством, что число, образованное

первыми двумя цифрами, будучи умноженным на среднюю цифру, даёт число,

образованное последними двумя цифрами.

Например, число: 12896: 12*8=96, значит число подходит.

+5
Ответы (1)
  1. 18 ноября, 11:52
    0
    Var

    i, n, a, b, c: longint;

    begin

    n : = 0;

    for i : = 10000 to 99999 do

    begin

    a : = i div 1000;

    b : = (i div 100) mod 10;

    c : = i mod 100;

    if a * b = c then n : = n + 1

    end;

    Writeln ('Найдено чисел: ', n)

    end.

    Результат работы программы:

    Найдено чисел: 286
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая подсчитывает общее количество целых пятизначных чисел, составленных из различных цифр, которые обладают тем ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, которая подсчитывает периметр квадрата, площадь которого равна а. 2. Написать программу, которая подсчитывает площадь равностороннего треугольника, периметр которого равен p
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Напишите программу, которая подсчитывает сумму всех цифр в данной строке. Например, в строке "Sochi-2014" сумма цифр равна 7. Формат входных данных Одна строка, возможно с пробелами, буквами, цифрами и спецсимволами.
Ответы (1)
Составить программу, которая подсчитывает общее количество целых четырёхзначных чисел, которые удовлетворяют условиям: a) abcd - четырехзначное число; b) a, b, c, d - разные цифры; c) ad - cd = a + b + c + d; В ответе укажите только число.
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)