Задать вопрос
29 декабря, 05:10

Дана матрица размера М х N'. В каждом столбце матрицы найти максимальный элемент. Язык паскаль

+4
Ответы (1)
  1. 29 декабря, 08:56
    0
    Var

    A:array[1 ... 100,1 ... 100] of integer;

    MAX, i, j, m, n:integer;

    begin

    randomize;

    MAX:=-32000;

    Readln (m, n) ;

    Writeln ('Исходная матрица:') ;

    for i:=1 to m do

    for j:=1 to n do

    begin

    a[i, j]:=random (10) ;

    writeln ('A[', i,',', j,']=', a[i, j]) ;

    end;

    for i:=1 to m do

    begin

    for j:=1 to n do

    if A[i, j]>MAX then

    MAX:=A[i, j];

    Writeln ('MAX[', i,']', MAX) ;

    MAX:=-32000;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана матрица размера М х N'. В каждом столбце матрицы найти максимальный элемент. Язык паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачку (Паскаль) Дана матрица B (4,4) 1) Найти произведение положительных элементов среди элеметов рассположенных выше побочной диагонали матрицы B. 2) Найти минимальный элемент во втором столбце матрицы B.
Ответы (1)
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
Составить программу для ввода обработки и печати массивов (одномерных и двухмерных) : Дана действительная матрица a размера (n*m), n, m≤10.
Ответы (1)
Оформить в виде подпрограмм-процедур в программе Pascal: Дана матрица действительных чисел M*N. Найти матрицу того же порядка, в которой элемент равен 1, если соответствующий ему элемент начальной матрицы больше, чем элемент, расположенный в его
Ответы (1)