Задать вопрос
15 октября, 14:13

Вычислить сумму ряда cos (n) / (n-1) ! с позиции N до позиции M.

+5
Ответы (1)
  1. 15 октября, 15:10
    0
    Var i, N, M : word;

    s : double;

    function fac (z : word) : longint;

    begin

    if (z < = 1) then

    fac : = 1

    else

    fac : = fac (z - 1) * z;

    end;

    begin

    repeat

    writeln ('введите N и M (от 3 до 36) ') ;

    readln (N, M) ;

    until (N > = 3) and (N < M) and (M < = 36) ;

    s : = 0;

    for i : = N to M do

    begin

    s : = s + (cos (n)) / (fac (i - 3)) ;

    end;

    writeln ('сумма ряда на интервале [', N, ',', M, '] = ', s)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить сумму ряда cos (n) / (n-1) ! с позиции N до позиции M. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Вычислить сумму ряда s = cos (x) + cos (x) * cos (x) + ... + cos (x) * cos (x) * ... * cos (x), для x и n введенных с клавиатуры.
Ответы (2)
Задача№1. Найти произведение цифр заданного трехзначного числа. Задача№2. Вычислить выражение y=cos (1) + cos (1/2) + cos (1/3) + ... + cos (1/n), где n вводить с клавиатуры. Задача№3. Даны действительные числа а1, а2 ... а n.
Ответы (1)
Размер окна текстового редактора - 20 строк по 64 символа в строке. Курсор находится в левом верхнем углу экрана и указывает на символ, стоящий в 25 - й строке и 5 - й позиции текста.
Ответы (1)
Задача номер 1 напечатать сумму элементов кратных одновременно двум или трем числового ряда 3, 6, 9, 2, 12, 2, 24 и задача 2 составить программу вычисления числового ряда для известного числа ряда N. Y = (1-2/5) + (2+4/10) + (3-8/15) + (4+16/20) + ..
Ответы (1)
Три десятичных числа (100,102,91) перевести в восьмеричную систему вычислить их сумму и перевести в десятичную систему вычислить их сумму и перевести в дестяричную Три двоичных числа перевести в 16-ую систему, вычислить их сумму и перевести в
Ответы (1)