Задать вопрос
28 марта, 03:57

Дано множество точек с координатами на плоскости.

Написать программу, которая использует подпрограммы и выведит на экран наименьшее расстояние между двумя точками.

+3
Ответы (1)
  1. 28 марта, 07:39
    0
    Const

    nm = 50; {максимальная длина массива}

    type

    Mas = array[1 ... nm] of real;

    var

    i, j, n: integer;

    x, y: Mas;

    d, dmin: real;

    function SqrDist (p, q: integer) : real;

    { Возвращает квадрат расстояния между точками }

    begin

    SqrDist : = sqr (x[q] - x[p]) + sqr (y[q] - y[p])

    end;

    begin

    Write ('Введите количество точек - > ') ;

    Readln (n) ;

    Writeln ('Вводите координаты каждой точки (x, y) через пробел') ;

    for i : = 1 to n do

    begin

    Write ('точка ', i, ': ') ;

    Readln (x[i], y[i]) ;

    end;

    dmin : = 1e10; { значение, заведомо большее реально возможного }

    for i : = 1 to n do

    for j : = i + 1 to n do

    begin

    d : = SqrDist (i, j) ;

    if dmin > d then dmin : = d

    end;

    Writeln ('Минимальное расстояние между точками равно ', sqrt (dmin) : 0:4)

    end.

    Тестовое решение:

    Введите количество точек - > 5

    Вводите координаты каждой точки (x, y) через пробел

    точка 1: 3.4 7.2

    точка 2: - 3 8.6

    точка 3: - 4.5 - 5.1

    точка 4: 6 - 2

    точка 5: 0 9

    Минимальное расстояние между точками равно 3.0265
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано множество точек с координатами на плоскости. Написать программу, которая использует подпрограммы и выведит на экран наименьшее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задачу решить двумя способами: с использованием подпрограммы-функции и подпрограммы-процедуры. Обязательно построение блок-схем алгоритмов! 1. Треугольник задан координатами своих вершин.
Ответы (1)
Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Задание 5 Вопрос: При помощи чего записываются вспомогательные алгоритмы на языке Паскаль? Выберите один из 4 вариантов ответа: 1) Тесты 2) Подзадачи 3) Подпрограммы 4) Подкоманды Задание 6 Вопрос: Какие существуют подпрограммы в языке Паскаль?
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)