Задать вопрос
20 января, 09:54

Дана матрица 4 Х5 построить одномерный массив b состоящий из наименьших значений элементов строк.

P. S Turbo Pascal

+1
Ответы (1)
  1. 20 января, 11:23
    0
    Uses crt;

    var a:array[1 ... 4,1 ... 5] of integer; b:array[1 ... 4] of integer;

    i, j, min:integer;

    begin

    for i:=1 to 4 do begin

    for j:=1 to 5 do begin

    a[i, j]:=1+random (9) ;

    write (a[i, j]:4) ;

    end;

    writeln;

    end;

    writeln;

    for i:=1 to 4 do begin

    min:=a[i, 1];

    for j:=1 to 5 do

    if min>a[i, j] then min:=a[i, j];

    b[i]:=min;

    end;

    for i:=1 to 4 do

    write (b[i]:4) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана матрица 4 Х5 построить одномерный массив b состоящий из наименьших значений элементов строк. P. S Turbo Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
Заполнить двухмерный массив состоящий из 5x5 элементов, случайными числами в диапазоне от 0 до 100. Сформировать одномерный массив, состоящий из минимальных элементов строк исходного и """сортировать его по убыванию.
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Напишите полностью программу в Turbo Pascal. Создать программу в Turbo Pascal ... Пользователь вводит n элементов массива. Требуется определить количество элементов, значение которых больше, чем у предыдущего элемента массива
Ответы (1)