Задать вопрос
23 ноября, 19:56

Дана матрица 5 Х5.

вывести ее в транспортированом виде, поменять местами строки со столбцами.

P. S Turbo Pascal

+5
Ответы (1)
  1. 23 ноября, 23:51
    0
    Program abc; var i, j: byte; arr1, arr2: array [1 ... 5] of array [1 ... 5] of integer; arr: array[1 ... 25] of integer; begin for i : = 1 to 25 do begin arr[i] : = i; end; writeln ('array1:') ; for i : = 1 to 5 do begin for j : = 1 to 5 do begin arr1[i][j] : = arr[ (i - 1) * 5 + j]; write (' ', arr1[i][j], ' ') ; end; writeln () ; end; writeln ('array2:') ; for i : = 1 to 5 do begin for j : = 1 to 5 do begin arr2[i][j] : = arr1[j][i]; write (' ', arr2[i][j], ' ') ; end; writeln () ; end; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана матрица 5 Х5. вывести ее в транспортированом виде, поменять местами строки со столбцами. P. S Turbo Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
Дана целочисленная матрица. Найти для каждой строки количество элементов, кратных пяти и из полученных результатов выбрать наибольший. Вывести матрицу, количества и максимум. В Turbo Pascal
Ответы (1)
Написать программу для "Pascal": Дана целочисленная матрица размерности (NxM). Поменять местами строки с max и min элементами.
Ответы (1)
Составьте блок-схему алгоритма решения задачи и программу на языке Turbo Pascal, ввод данных организовать с клавиатуры. Поменять местами значения переменных А и B. Вывести новые значения А и B
Ответы (1)
Напишите полностью программу в Turbo Pascal. Создать программу в Turbo Pascal ... Пользователь вводит n элементов массива. Требуется определить количество элементов, значение которых больше, чем у предыдущего элемента массива
Ответы (1)