Задать вопрос
27 августа, 11:45

Написать программу, которая вводит целые числа и складывает их, пока не будет введено число 0. вывести сумму чисел, введённых до 0.

+4
Ответы (1)
  1. 27 августа, 14:14
    0
    var

    sum, num: integer;

    begin

    repeat

    readln (num) ;

    if (num = 0) then

    break;

    write (sum, ' + ', num, ' = ') ;

    sum : = sum + num;

    writeln (sum) ;

    until (false) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая вводит целые числа и складывает их, пока не будет введено число 0. вывести сумму чисел, введённых до 0. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте схему алгоритма программы, которая будет осуществлять ввод чисел до тех пор, пока не будет введено число 17. Как только будет введено число 17, программа должна вывести количество введенных чисел
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Ребят, помоги в паскале. напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0. В конце работы программы на экран выводится сумма и произведение введенных чисел.
Ответы (1)
Напишите алгоритм программы которая вводит числа с клавиатуры до тех пор пока не будет введено число 0. В конце работы вычислить сумму и произведение введенных чисел
Ответы (1)
1) Напишите программу, которая вводит натуральное число N и нахо дит сумму всех натуральных чисел от 1 до N. Используйте сначала цикл с условием, а потом - цикл с переменной.
Ответы (1)