Задать вопрос
19 мая, 06:59

Найти максимальный из элементов, имеющих четный индекс. Пример: массив 7 2 6 5 4 4 10 3 9 элементы с четными индексами 2 5 4 3 максимальный из них 5. Паскаль АВС.

+2
Ответы (1)
  1. 19 мая, 10:52
    0
    Const

    n = 15;

    var

    x: array[1 ... n] of integer;

    i, max: integer;

    begin

    Randomize;

    Write ('Элементы массива: ') ;

    for i : = 1 to n do

    begin

    x[i] : = Random (20) ;

    Write (x[i]:3)

    end;

    max : = x[2]; i : = 4;

    while i < = n do

    begin

    if max < x[i] then max : = x[i];

    i : = i + 2

    end;

    Writeln;

    Writeln ('Max=', max)

    end.

    Тестовое решение:

    Элементы массива: 17 12 18 12 11 14 18 19 16 16 9 13 7 3 13

    Max=19
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти максимальный из элементов, имеющих четный индекс. Пример: массив 7 2 6 5 4 4 10 3 9 элементы с четными индексами 2 5 4 3 максимальный ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сравните. P. S. напишите решение а) 285 (индекс 10) и 11D (индекс 16) б) 111111 (индекс 2) и 1111 (индекс 8) в) 6 С (индекс 16) и 101001 (индекс 2) г) 55 (индекс 16) и 125 (индекс 8)
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Составить программу, которая заполняет массив А[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает. Вывести на экран исходный и полученный массив.
Ответы (1)
Дан массив MAS вещественного типа, содержащий 20 положительных и отрицательных элементов. Сформировать массив С из положительных элементов массива MAS, имеющих четный индекс. Найти сумму квадратов элементов нового массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)