Задать вопрос
9 ноября, 18:20

В массиве A[100] найти среднее арифметическое, кратных 5 и кратных 3 элементов массива.

+2
Ответы (1)
  1. 9 ноября, 18:40
    0
    var

    i, n:integer;

    p:real;

    a:array[1 ... 100]of integer;

    begin

    for i:=1 to 100 do

    begin

    a[i]:=random (50) + 1;

    write (a[i],' ') ;

    if (a[i] mod 5=0) and (a[i] mod 3=0) then

    begin

    p:=p+a[i];

    n:=n+1;

    end;

    end;

    writeln;

    p:=p/n;

    writeln ('Ответ: ', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве A[100] найти среднее арифметическое, кратных 5 и кратных 3 элементов массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)