Задать вопрос
16 марта, 07:10

Pascal. составьте программу для нахождения суммы отрицательных четных элементов двумерного массива

+4
Ответы (1)
  1. 16 марта, 09:21
    0
    Program aliona;

    const n = 10;

    var a:array[1 ... n, 1 ... n] of integer;

    i, j, s:integer;

    begin

    randomize;

    for i:=1 to n do

    for j:=1 to n do

    begin

    a[i, j]:=random (30) ;

    write ('а (', i, ',', j, ') = ', a[i, j]) ;

    end;

    s:=0;

    for i:=1 to n do begin

    for j:=1 to n do begin

    if a[i] (mod 2 = 0) and (a[i]<0) then s:=s+a[i];

    writeln ('s=', s) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal. составьте программу для нахождения суммы отрицательных четных элементов двумерного массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль, составьте программу для двумерного массива: Найти произведение отрицательных элементов указанной строки двумерного массива размером 4*5 целых чисел.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)