Задать вопрос
10 января, 20:35

Напишите процедуру которая принимает числовой параметр-Возраст человека в годах и выводит этот возраст со словом год, года или лет. Например 21 год, 22 года, 12 лет

+1
Ответы (1)
  1. 10 января, 21:04
    0
    Procedure Age (n: integer) ;

    var

    m: integer;

    s: string;

    begin

    if ((n > = 11) and (n = 111) and (n < = 120)) then s : = 'лет'

    else begin

    m : = n mod 10;

    case m of

    1: s : = 'год';

    2 ... 4: s : = 'года';

    else s : = 'лет'

    end

    end;

    Writeln ('Возраст равен ', n, ' ', s)

    end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите процедуру которая принимает числовой параметр-Возраст человека в годах и выводит этот возраст со словом год, года или лет. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Помогите написать программу в python Уровень C. Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год", "года" или "лет". Например, "21 год", "22 года", "25 лет".
Ответы (2)
напишите программу, которая вводит возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом "год", "года" или "лет". например: 21 год, 22 года, 25 лет
Ответы (1)
Напишите процедуру в Паскале, которая принимает параметр - натуральное число N - и выводит на экран линию из N символов '-'.
Ответы (1)
Напишите процедуру которая принимает параметр - натуральное число N и выводит первые N чисел Фибоначчи
Ответы (1)