Задать вопрос
26 июня, 16:50

Решить задачу на языке программирования Pascal.

В текущем месяце бригада в каждый последующий день работы выпускала на три изделия больше, чем в предыдущий. В первый день было выпущено 42 изделия, что составило 67% дневной нормы. В месяце 26 рабочих дней. Сумеет ли бригада выполнить месячную норму?

+1
Ответы (2)
  1. 26 июня, 17:06
    0
    Var i, x, s, n:integer;

    begin

    x:=42;

    n:=round (42/67*100) * 26;

    for i:=1 to 26 do

    begin

    s:=s+x;

    x:=x+3;

    end;

    writeln ('Норма: ', n) ;

    writeln ('Сделано: ', s) ;

    if s>=n then writeln ('Норма выполнена')

    else writeln ('Норма не выполнена') ;

    end.
  2. 26 июня, 20:31
    0
    Var

    i:integer;

    answer:integer;

    n:integer;

    begin

    answer:=42;

    n:=Trunc (42/67) * 100;

    for i:=1 to 26 do

    begin

    answer:=answer+3;

    if answer then Writeln (i,'Бригада не выполнила норму')

    else Writeln (i,'Бригада выполнила норму') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить задачу на языке программирования Pascal. В текущем месяце бригада в каждый последующий день работы выпускала на три изделия больше, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Составить программу в Pascal ABC, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число. После этого выводит сообщение о том, сколько дней осталось до конца месяца.
Ответы (1)
Составить программу, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число. После этого выводит сообщение о том, сколько дней осталось до конца месяца.
Ответы (1)
Какое число в текущем году приходится на третью среду марта? Какой день недели в текущем году приходится на 31 декабря? Какое число в текущем году приходится на последнее воскресенье мая?
Ответы (1)
В первый день строительства Колизея работал один рабочий и уложил 100 камней. Каждый последующий день рабочих становилось больше на один и каждый приносил на 1 камень больше, чем предыдущий.
Ответы (1)