Задать вопрос
26 января, 22:47

Написать программу, в которой надо узнать состоит ли двузначное число из одинаковых цифр.

+3
Ответы (1)
  1. 27 января, 00:28
    0
    C:

    #include

    int main ()

    {

    int a;

    scanf ("%d", &a) ;

    if (a % 10 = = (a - a % 10) / 10)

    {

    printf ("YES") ;

    }

    else

    {

    printf ("NO") ;

    }

    }

    Pascal:

    Program z1;

    var a: integer;

    begin

    readln (a) ;

    if a mod 10 = (a - a mod 10) / 10 then

    writeln ("YES")

    else

    writeln ("NO") ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, в которой надо узнать состоит ли двузначное число из одинаковых цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1. С клавиатуры вводится число от 100 до 9999. Если число трехзначное, то найти произведение его цифр. Если четырехзначное, то найти сумму этих цифр. 2. Определить, состоит, ли двузначное число, введенное с клавиатуры из одинаковых цифр.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)