Задать вопрос
26 мая, 01:34

Напечатать все пифагоровы числа не привышающие 30 (алгоритм)

+3
Ответы (1)
  1. 26 мая, 03:24
    0
    Перебираешь все взаимно простые m > n разной четности, так чтобы m*m было меньше 30. И формируешь тройки по формуле:

    k * (m*m-n*n, 2*m*n, m*m + n*n)

    Например так:

    function gcd (a, b: integer) : integer;

    begin

    if b = 0 then gcd : = a

    else if (a > b) and (b > 0) then gcd : = gcd (b, a mod b)

    else gcd : = gcd (b, a) ;

    end;

    procedure Print (m, n:integer) ;

    var i, a, b, c: integer;

    begin

    repeat

    i : = i + 1;

    a : = (m*m-n*n) * i;

    b : = 2*m*n*i;

    c : = (m*m+n*n) * i;

    if c < 30 then

    writeln (a, ' ', b, ' ', c)

    else break;

    until false;

    end;

    var m, n, s: integer;

    begin

    s : = Trunc (Sqrt (30)) ;

    for m : = 1 to s do

    for n : = m + 1 to s do

    if (gcd (n, m) = 1) and ((m mod 2) (n mod 2)) then

    Print (n, m)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напечатать все пифагоровы числа не привышающие 30 (алгоритм) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Какой алгоритм называется линейным? А. Алгоритм, в котором имеется ввод данных, вычисления и вывод результатов. Б. Алгоритм, в котором для получения результатов последовательно выполняются все операторы по одному разу В.
Ответы (1)
Даны три действительных числа. Если только два из них равны между собой, то возвести все числа в квадрат и напечатать в противном случае напечатать все три числа. Написать программу
Ответы (1)
исключи из предложенных сочетаний слов те, которые невозможны в информатике: 1) линейный алгоритм 2) прямой алгоритм 3) циклический алгоритм 4) разветвляющийся алгоритм
Ответы (2)
Алгоритм выполнения домашнего задания. Алгоритм рецепта приготовления пирога. Алгоритм мытья посуды. Алгоритм путешествия Колобка в известной сказке. Оформление.
Ответы (1)