Задать вопрос
11 февраля, 12:03

Нужно составить алгоритм

задача: в последовательности целых положительных чисел определить максимальное четное число и его порядковый номер

+3
Ответы (1)
  1. 11 февраля, 12:49
    0
    var

    i, err, buf2: integer;

    buf: string;

    max: array [0 ... 1] of integer;

    begin

    writeln ('Конец последовательности - пустая строка') ;

    repeat

    inc (i) ;

    readln (buf) ;

    val (buf, buf2, err) ;

    if (err > 0) then break;

    if ((buf2 > max[1]) and (buf2 mod 2 = 0)) then

    begin

    max[1] : = buf2;

    max[0] : = i;

    end;

    until false;

    writeln ('[', max[0], '] = > ', max[1]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно составить алгоритм задача: в последовательности целых положительных чисел определить максимальное четное число и его порядковый номер ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется четное число.
Ответы (1)
Напишите программу в PaskalABC, которая в последовательности натуральных чисел определяет максимальное чётное число. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет минимальное четное число. Программа получает на вход кол-во чисел в последовательности, а затем сами числа. В последовательности всегда имеется четное число.
Ответы (1)
На с + + Мальчик-романтик из царства-государства дарит цветы незнакомым дамам-девушкам. Известно, что он дарит цветок каждой пятой даме-девушке, но при этом не дарит цветок, если порядковый номер дамы-девушки кратен 25.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)