Задать вопрос
19 августа, 02:01

Написать программу в паскале

Дано три массива A, B, C состоящее из 10 элементов. Присвоить массиву D среднее арифметическое каждого элемента этих трех массивов.

+1
Ответы (1)
  1. 19 августа, 04:02
    0
    Uses crt;

    Var a, b, c, d; array [1 ... 10] of integer;

    I:integer;

    Begin

    Clrscr;

    Begin

    For i:=1 to 10 do

    Begin

    a[i]:=random (50) + 1;

    b[i]:=random (50) + 1;

    c[i]:=random (50) + 1;

    d[i]: = (a[i]+b[i]+c[i]) div 3;

    end;

    Write ('A) ') ;

    For i:=1 to 10 do

    write (a[i],' ') ;

    Writeln;

    write ('B) ') ;

    For i:=1 to 10 do

    write (b[i],' ') ;

    Writeln;

    Write ('C) ') ;

    For i:=1 to 10 do

    write (c[i],' ') ;

    Writeln;

    Writeln ('Средние значения ') ;

    Write ('D) ') ;

    For i:=1 to 10 do

    write (d[i],' ') ;

    Writeln;

    Readkey;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в паскале Дано три массива A, B, C состоящее из 10 элементов. Присвоить массиву D среднее арифметическое каждого ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан алгоритм: Начало Присвоить a значение 1 Присвоить b значение 1 Присвоить c значение 0 Пока a меньше чем 1001 Начало цикла Присвоить b значение b * a Присвоить a значение a + 1 Конец цикла Пока b делится на 6 Начало цикла Присвоить c значение c +
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)