Задать вопрос
24 ноября, 14:53

Написать программу и блок схему

дана матрица

А = {-10 20 13

-22 11 - 5

4 12 - 8}

определить среднее арифметическое отрицательных и положительных элементов

+1
Ответы (1)
  1. 24 ноября, 16:21
    0
    Var a : array [1 ... 3] of array [1 ... 3] of integer;

    i, j : shortint;

    c1, c2, s1, s2 : integer;

    begin

    a[1][1]:=-10;

    a[1][2]:=20;

    a[1][3]:=13;

    a[2][1]:=-22;

    a[2][2]:=11;

    a[2][3]:=-5;

    a[3][1]:=4;

    a[3][2]:=12;

    a[3][3]:=-8;

    s1:=0; s2:=0; c1:=0; c2:=0;

    for i:=1 to 3 do begin

    for j:=1 to 3 do begin

    if a[i][j]>0 then begin

    s1:=s1+a[i][j];

    inc (c1) ;

    end else begin

    s2:=s2+a[i][j];

    inc (c2) ;

    end;

    end;

    end;

    writeln (s1/c1:0:0) ;

    writeln (s2/c2:0:2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу и блок схему дана матрица А = {-10 20 13 -22 11 - 5 4 12 - 8} определить среднее арифметическое отрицательных и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
ПаскальАВС. №1. Вычислить сумму и число положительных элементов матрица А[N, N], находящихся над главной диагональю. №2. Дана вещественная матрица А размера n x m.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
Дана матрица А. Написать программу определения количества положительных и отрицательных элементов матрицы. Язык Visual Basic.
Ответы (1)
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)