Задать вопрос
12 октября, 09:06

Помогите с паскалем. В линейный массив вещественных чисел на 8-е место вставить элемент, равный сумме первых 10 элементов массива.

+1
Ответы (1)
  1. 12 октября, 11:43
    0
    Var n, i: Integer;

    sum: Double;

    a: Array[1 ... 1000] of Double;

    begin

    ReadLn (n) ;

    for i:=1 to n do Read (a[i]) ;

    sum:=0;

    for i:=1 to 10 do sum:=sum+a[i];

    a[8]:=sum;

    WriteLn ('--') ;

    for i:=1 to n do Write (a[i]:0:3, ', ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с паскалем. В линейный массив вещественных чисел на 8-е место вставить элемент, равный сумме первых 10 элементов массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)
Ввести массив F (n) вещественных чисел. Если последний элемент массива положительный, то найти max среди элементов массива и заменить его значений последний элемент массива. Массив распечатать. Иначе - дать сообщение "Массив остался без изменений"
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)