Задать вопрос
16 января, 09:22

В линейном массиве вещественных чисел а (n) заменить все элементы большие 10. на число с.

+5
Ответы (1)
  1. 16 января, 10:52
    0
    Const

    k = 20;

    var

    a: array[1 ... k] of integer;

    c, i, n: integer;

    begin

    Randomize;

    write ('Введите число элементов массива (не более 20) : ') ;

    readln (n) ;

    write ('Введите целое число С: ') ;

    readln (c) ;

    write ('Исходный массив: ') ;

    for i : = 1 to n do

    begin

    a[i] : = Random (41) - 20;

    write (a[i], ' ')

    end;

    write (#13#10,'Массив-результат: ') ;

    for i : = 1 to n do

    begin

    if a[i] > 10 then a[i] : = c;

    write (a[i], ' ')

    end

    end.

    Тестовое решение:

    Введите число элементов массива (не более 20) : 18

    Введите целое число С: 99

    Исходный массив: - 1 - 17 - 15 16 12 - 12 14 19 - 1 18 13 11 - 17 - 6 - 17 - 2 20 - 14

    Массив-результат: - 1 - 17 - 15 99 99 - 12 99 99 - 1 99 99 99 - 17 - 6 - 17 - 2 99 - 14
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В линейном массиве вещественных чисел а (n) заменить все элементы большие 10. на число с. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
В питоне Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b).
Ответы (1)
1) В числовом одномерном массиве все элементы массива, кратные 3, возвести в куб. В новом массиве найти сумму всех членов массива.
Ответы (1)