Задать вопрос
20 марта, 07:54

Помогите решить задачу в паскале.

Даны три массива:

A = {17.2, 9.3, 14.5, - 11.7, 4.3,

5.9, - 11.9, 12.3, - 14.1, - 15.3},

B = {-1.2, 4.2, 5.9, - 18.1, 21.2,

-3.1, - 5.3, - 12.2, 21.4, - 4.5, 8.2, 9.4},

C = {3.5, 8.4, - 3.2, 4.5, - 8.4,

-9.5, 1.5,9.3}.

Для

каждого из массивов найти суммы положительных элементов. Использовать

подпрограмму.

+3
Ответы (2)
  1. 20 марта, 08:00
    0
    Type

    V = array of real;

    function SumPos (a:V) : real;

    var

    i: integer;

    s: real;

    begin

    s : = 0;

    for i : = 0 to Length (a, 0) - 1 do

    if a[i] > 0 then s : = s + a[i];

    Result : = s

    end;

    var

    A, B, C: V;

    begin

    A : = new real[10] (17.2, 9.3, 14.5, - 11.7, 4.3, 5.9, - 11.9, 12.3, - 14.1, - 15.3) ;

    B : = new real[12] (-1.2, 4.2, 5.9, - 18.1, 21.2, - 3.1, - 5.3, - 12.2, 21.4, - 4.5, 8.2, 9.4) ;

    C : = new real[8] (3.5, 8.4, - 3.2, 4.5, - 8.4, - 9.5, 1.5, 9.3) ;

    writeln ('Сумма положительных элементов массива А ', SumPos (A)) ;

    writeln ('Сумма положительных элементов массива B ', SumPos (B)) ;

    writeln ('Сумма положительных элементов массива C ', SumPos (C)) ;

    end.

    Тестовый прогон:

    Сумма положительных элементов массива А 63.5

    Сумма положительных элементов массива B 70.3

    Сумма положительных элементов массива C 27.2
  2. 20 марта, 10:00
    0
    function subprogram (a: array of real) : real;

    begin

    foreach obj: real in a do

    if (obj > 0) then

    result + = obj;

    end;

    var

    a: array of real : = (17.2, 9.3, 14.5, - 11.7, 4.3, 5.9, - 11.9, 12.3, - 14.1, - 15.3) ;

    b: array of real : = (-1.2, 4.2, 5.9, - 18.1, 21.2, - 3.1, - 5.3, - 12.2, 21.4, - 4.5, 8.2, 9.4) ;

    c: array of real : = (3.5, 8.4, - 3.2, 4.5, - 8.4, - 9.5, 1.5, 9.3) ;

    begin

    writeln ('a = > ', subprogram (a)) ;

    writeln ('b = > ', subprogram (b)) ;

    writeln ('c = > ', subprogram (c)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачу в паскале. Даны три массива: A = {17.2, 9.3, 14.5, - 11.7, 4.3, 5.9, - 11.9, 12.3, - 14.1, - 15.3}, B = {-1.2, 4.2, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)