Задать вопрос
31 декабря, 10:15

Составить программу которая находит количество натуральных чисел которые не делятся ни на одно из чисел 2,7,11

+4
Ответы (1)
  1. 31 декабря, 12:27
    0
    var

    s, k, err: integer;

    str: string;

    begin

    writeln ('Введённая пустая строка (без каких-либо символов) считается концом последовательности и, собственно, завершает выполнение программы, как бы говоря ей: "Эй, подруга! Выведи-ка количество чисел, не делящихся ни на два, ни на семь, ни на одиннадцать!"') ;

    while (true) do

    begin

    readln (str) ;

    val (str, k, err) ;

    if (err > 0) then break;

    if ((k mod 2 = 0) and (k mod 7 = 0) and (k mod 11 = 0)) then

    inc (s) ;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу которая находит количество натуральных чисел которые не делятся ни на одно из чисел 2,7,11 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Из ряда натуральных чисел от 1 до 2000 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Из ряда натуральных чисел от 1 до 1500 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и: а) находит элементы с нулевыми значениями б) находит индексы четных элементов в) подсчитывает количество отрицательных элементов г) определяет, есть ли в этом
Ответы (1)