Задать вопрос
2 июня, 06:43

Напишите линейную программу в результате выполнения которой в целочисленной переменной S получится перевернутое целое четырехзначное число k. Например:

если k=1357, то S=7531

+4
Ответы (1)
  1. 2 июня, 07:16
    0
    Var a, b, c, d, s, k: integer;

    begin

    write ('Введите k: ') ; readln (k) ;

    a : = k div 1000; {тысячи}

    b : = (k mod 1000) div 100; {сотни}

    c : = (k mod 100) div 10; {десятки}

    d : = k mod 10; {единицы}

    s : = d * 1000 + c * 100 + b * 10 + a;

    writeln ('k = ', k, #10, 's = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите линейную программу в результате выполнения которой в целочисленной переменной S получится перевернутое целое четырехзначное число ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите линейную программу, в результате выполнения которой целочисленные переменные x и y обменяются значениями. При этом нельзя использовать дополнительные переменные.
Ответы (1)
Запишите на алгоритмическом языке алгоритм, в результате которого переменной A будет присвоено значение переменной B, переменной B-значение переменной C, а переменной C-значение переменной A. Используйте не более одной промежуточной переменной.
Ответы (1)
Напишите оператор присваивания, в результате выполнения которого целочисленной переменной h присвоится значение цифры, стоящей в разряде сотен в записи положительного целого числа k (например, если k=28 769, то h=7).
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X) ; 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)