Задать вопрос
2 октября, 23:58

Определить количество и вычислить сумму элементов одномерного массива N, кратных трем.

+2
Ответы (1)
  1. 3 октября, 00:35
    0
    Var a: array[1 ... 1000] of integer; n, i, amount, sum: integer;

    begin

    read (n) ;

    amount : = 0;

    sum : = 0;

    for i : = 1 to n do

    begin

    read (a[i]) ;

    if a[i] mod 3 = 0

    then

    begin

    sum : = sum + a[i];

    amount : = amount + 1;

    end;

    end;

    writeln (amount, ' ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить количество и вычислить сумму элементов одномерного массива N, кратных трем. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
С клавиатуры задается число N не превышающее 20, определяющее количество элементов одномерного целочисленного массива. Затем вручную заполняется сам массив из N элементов.
Ответы (1)